Autopsy 4.14.0 on kali Linux and Java 1.8.0_242-b07

Please don’t take this as an attack, but the chief issue here is that you are trying to run Autopsy as root. There is very little reason to do that.

It is unclear from your descriptions what user’s environment you are setting when you edit your .bashrc, but know this: If you set the a regular user’s environment variables and then execute your commands with “sudo”, you aren’t importing the user’s environment to the command. Some Linuxes don’t even have a root user account (I believe Kali is one), and the sudo command won’t even pick up globally set environmental variables (e.g., /etc/bash.bashrc).

I’d recommend you install the dependencies for Linux, then unzip the autopsy Zip file in a regular user account. You’ll have fewer issues setting up (probably none) and you’ll pose less danger to your system.

If you need to run as root, and you are using the sudo command to switch to root or execute the command, try using “sudo -E” to preserve your environment.

No, John, no worries. I don’t perceive that was an attack.

I am a newbie and did not want to cover that up.

I am not executing commands using sudo. It all started with the need to set up Slueth Kit and Autopsy.

I had numerous issues that people here, including you, helped me with.

The restm like that pesky path setting, I can figure out.

In any case, thanks to everyone for your help.

I am working on my first case with Autopsy now.

I’ll be back I am sure with questions about Autopsy.


Hey all:

For posterity–and perhaps for future noobs, I should note down that I did manage to find what the issue was with my path not being recognized in .bashrc.

Turns out there was a line at the bottom of the .bashrc where the standard paths were being set. This line was overriding mine, which I added at the top. I deleted my line and simply added the new path to the preexisting line at the bottom of the .bashrc.

Now I can invoke autopsy from the shell prompt.

Exhausting to struggle with such basics. But I have to say I learned a whole lot.

Thanks to all. I apologize for these rookie mistakes, but we all have to start somewhere. No one is born with this knowledge.