Autopsy not running properly with no error message

I have installed everything as instructed from “Running_Linux_OSX.txt”.
Fired up autopsy with ./autopsy from “bin”. However, after loaded there are no “create new case” windows pop up. I have checked my Java bin folder jfxrt.jar is not in the directory.
Im running OSX Catalina 10.15.4
Java version :
openjdk version “1.8.0_242”
OpenJDK Runtime Environment (build 1.8.0_242-b07)
OpenJDK 64-Bit Server VM (build 25.242-b07, mixed mode)

See this thread - you probably need a different version of the jdk.

Thanks @apriestman. This is exactly the same issue that Im facing at the moment. I tried uninstall liberica-jdk8 and install liberica-jdk8-full instead. However, it does not seems to be resolving the issue.` I tried uninstall everything and do it all over again and the problem persist, and I’m not seeing any error message that’s odd…

I have attached some some info below.

echo $JAVA_HOME

/Library/Java/JavaVirtualMachines/liberica-jdk-8-full.jdk/Contents/Home

sh unix_setup.sh


Checking prerequisites and preparing Autopsy:


-n Checking for PhotoRec…

found in /usr/local/bin

-n Checking for Java…

found in /Library/Java/JavaVirtualMachines/liberica-jdk-8-full.jdk/Contents/Home

-n Checking for Sleuth Kit Java bindings…

found in /usr/local/share/java

-n Copying sleuthkit-4.8.0.jar into the Autopsy directory…

done

Autopsy is now configured. You can execute bin/autopsy to start it

Java -version

openjdk version “1.8.0_242”

OpenJDK Runtime Environment (build 1.8.0_242-b07)

OpenJDK 64-Bit Server VM (build 25.242-b07, mixed mode)

After reinstalling the JDK did you also remove the Mac OS equivalent of the “.autopsy” directory. I don’t know off the top of my head where it is located on Mac OS but if it’s not in your home directory it might be under “~/Library/Application Support”. You could run a search for “autopsy.log” to find it.

The location for removing the Autopsy configuration setting on a Mac is ~/Library/Application Support/Autopsy. The Running_Linux_OSX.txt file is not current.

Running Autopsy on a Mac is a bit trickier than on Linux and Windows. My success involved, roughly:

  1. installing the bellsoft-jdk8u232+10-macos-amd64.dmg package. For those using the brew package manager, I didn’t find a previous version than the current u242, so I had to download from Bellsoft.

  2. linking openjdk to liberica

    % ln -s /Library/Java/JavaVirtualMachines/liberica-jdk-8-full.jdk/Contents/Home /usr/local/opt/openjdk

  3. Building sleuthkit-4.8.0 from source; the brew package will not do. It is compiled with an incompatible version of openjdk. Two key points in the build: first complete step 1, then install the libpq and ant along with the other dependecies (libewf, afflib, etc).

    NOTE: when you install “ant”, do so with the “–ignore-depedencies” or brew will pull the openjdk package.

    NOTE 2: I haven’t been able to compile with openssl support; if someone knows the trick, drop me a line.

  4. Setting the JAVA_HOME variable; I set it in the .zshrc for repeated use:

    % echo “export JAVA_HOME=$(/usr/libexec/java_home -v 1.8)” >> ~/.zshrc

    NOTE: Restart terminal or execute “source .zshrc” to set the variable before proceeding to the next step.

  5. Change directories to the Autopsy-4.14.0 directory and execute the “unix_setup.sh”

This was from memory, so I hope I didn’t skip a step and that it helps you solve your Mac installation problems. That said, know that Mac installations don’t support the Timeline feature, and I have not found the video playback feature to work. I am still testing features…

@John_Lehr Yes, the only way to get Autopsy running on Mac currently is to build the sleuthkit from source.

FYI: Running_Linux_OSX.txt has been updated in the last couple of days to get the ‘full’ version of the latest OpenJDK distribution from Bellsoft via brew using ‘brew cask install liberica-jdk8-full’.
I haven’t tried this personally because I don’t have a Mac but if you could confirm that this approach to getting the JDK works for you it would be much appreciated.

Thanks.

Confirmed that the brew liberica-jdk8-full package works to run Autopsy, but that was still with a sleuthkit,jar compiled with u232. I think my issue, if memory serves, was that a sleuthkit compiled with u242 would through errors on Autopsy start and u232 did not.

It could be that I was did not have the full version installed. I know little about java or the sleuthkit.jar. If I get a chance, I’ll recompile sleuthkit with u242 and report back.

@John_Lehr Yeah, that’s probably it. We know that u232 included JavaFX and in u242 you only get Java FX in the “full” package. Building TSK with the non-full version of u242 would definitely have resulted in errors being thrown on startup.
Thanks.

Great! I remembered that I also had to link /usr/local/opt/openjdk to the Liberical home directory to get sleuthkit to compile. I added it to my instructions post above.

Hi, can you please write is step by step on how to install autopsy on mac, because im confused i stopped here:

  1. Set JAVA_HOME environment variable to location of JRE installation.
    e.g. add the following to ~/.bashrc
    export JAVA_HOME=$(/usr/libexec/java_home -v 1.8)

now what should i do please …

@3zoz

  1. % echo $JAVA_HOME
    you should see the following
    /Library/Java/JavaVirtualMachines/liberica-jdk-8-full.jdk/Contents/Home

  2. brew install --build-from-source sleuthkit

  3. Navigate / cd to autopsy folder and
    sh unix_setup.sh

I think that’s it. However, I’m still getting a blank autopsy screen/GUI on launch.

@John_Lehr @apriestman
I uninstalled sleuth kit and reinstall from source, when I sh unix_setup.sh I got the following error.

-n Checking for PhotoRec…

found in /usr/local/bin

-n Checking for Java…

found in /Library/Java/JavaVirtualMachines/liberica-jdk-8-full.jdk/Contents/Home

-n Checking for Sleuth Kit Java bindings…

ERROR: sleuthkit-4.8.0.jar not found in /usr/share/java/ or /usr/local/share/java/.

Please install the Sleuth Kit Java bindings file.

See https://github.com/sleuthkit/sleuthkit/releases.

@James_Khor

I appreciate your help but got this message when I navigate to /Autospy and
sh unix_setup.sh

Checking prerequisites and preparing Autopsy:


-n Checking for PhotoRec…

found in /usr/local/bin

-n Checking for Java…

ERROR: JAVA_HOME environment variable must be defined.

Hi guys
I finished installing it and seems everything goes smoothly, however, when launching autopsy from terminal, i am getting a blank page!!

Any advice

Thanks

sudo su
export JAVA_HOME=/usr/lib/jvm/bellsoft-java8-full-amd64
exit
sh unix_setup.sh

I have same issue but with windows. Windows 8.1 .I download and run autopsy, but its blank, new case window don’t appear.Kindly tell me any solution.

I have some issue but with windows. Windows 8.1 .I download and run autopsy, but its blank, new case window don’t appear.Kindly tell me any solution.

I have some issue but with windows. Windows 8.1 .I download and run autopsy, but its blank, new case window don’t appear.Kindly tell me any solution.