Autopsy giving an error and won't run on macOS version 10.15.7

I have the 2019 MacBook Pro and it is running macOS Catalina version 10.15.7
When I run Autopsy in Terminal bin/autopsy
it gives out this error message:

org.netbeans.InvalidException: StandardModule:org.sleuthkit.autopsy.core jarFile: /Users/t/Desktop/autopsy-4.16.0/autopsy/modules/org-sleuthkit-autopsy-core.jar: java.lang.IllegalArgumentException: java.lang.reflect.InvocationTargetException

The options is to exit or disable modules and continue

So when I clicked on disable modules and continue, it opens Autopsy but its empty and I can’t do anything like create a new case etc

The instruction says to uninstall any third party java installations… so when I run brew cask list, the only two installations are Liberica-jdk8-full and android-sdk… I can’t uninstall android-sdk as I need it to work on other assignments

1 Like

That condition is often a sign that you tried to run Autopsy before you had it properly installed. Delete the Autopsy support folder and try again:

rm -rf ~/Library/Application\ Support/autopsy

I ran that in the autopsy folder and it still gives me an error

I recommend, then, that you carefully work through this guide:

https://slo-sleuth.github.io/tools/InstallingAutopsyOnMacOS.html

I updated it recently when I installed Sleuthkit 4.16 on macOS 11. Don’t assume you have already done a step, just start afresh.

yeah, that’s what I used to download it in the first place. think its best for me to see if I can download it on linux or windows as I keep getting the same errors… but thank you

I am receiving the same error on my mac. Did you happen to ever find a solution?