Autopsy not running on MacOS Ventura 13.4.1 - Java Errors

I’ve tried to get Autopsy working on a MacBook Pro Ventura 13.4.1. I’ve done every step described seen on Everything (compilings, autopsy self checks ond so on) worked fine.

But by trying to start autopsy i’ve got errors because of a missing Java. No problem, i fixed it in autopsy.conf by adding a line jdkhome=$JAVA_HOME at the end.

Then i tried to start autopsy and i always get an empty gray screen and Java-Errors like the following:

Start error message
Juli 20, 2023 4:30:23 PM org.netbeans.ProxyURLStreamHandlerFactory register
SCHWERWIEGEND: No way to find original stream handler for jar protocol
java.lang.reflect.InaccessibleObjectException: Unable to make field transient accessible: module java.base does not “opens” to unnamed module @1936f0f5
at java.base/java.lang.reflect.AccessibleObject.throwInaccessibleObjectException(
at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(
at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(
at java.base/java.lang.reflect.Field.checkCanSetAccessible(
at java.base/java.lang.reflect.Field.setAccessible(
at org.netbeans.ProxyURLStreamHandlerFactory.register(
at org.netbeans.JarClassLoader.(
at org.netbeans.MainImpl.execute(
at org.netbeans.MainImpl.main(
at org.netbeans.Main.main(

java.lang.UnsupportedOperationException: The Security Manager is deprecated and will be removed in a future release
at java.base/java.lang.System.setSecurityManager(
at org.netbeans.TopSecurityManager.install(
at org.netbeans.core.NbLifecycleManager.advancePolicy(
at org.netbeans.core.startup.Main.start(
at java.base/

End errormessage

I’ve tried different java-versions (which you can see below copied from my terminal):

theUser@DDK-MB03-23 ~ % j17

openjdk version “17.0.7” 2023-04-18
OpenJDK Runtime Environment Homebrew (build 17.0.7+0)
OpenJDK 64-Bit Server VM Homebrew (build 17.0.7+0, mixed mode, sharing)
JavaHome: /opt/homebrew/Cellar/openjdk@17/17.0.7/libexec/openjdk.jdk/Contents/Home

theUser@DDK-MB03-23 ~ % j20

openjdk version “20.0.1” 2023-04-18
OpenJDK Runtime Environment Temurin-20.0.1+9 (build 20.0.1+9)
OpenJDK 64-Bit Server VM Temurin-20.0.1+9 (build 20.0.1+9, mixed mode)
JavaHome: /Library/Java/JavaVirtualMachines/temurin-20.jdk/Contents/Home

Has anybody any ideas what and how to fix?

I’ve tried to work with earlier java-versions too, but then i’ll get other errors like that:

Start errormessage
org.netbeans.InvalidException: StandardModule:org.sleuthkit.autopsy.core jarFile: /Users/petersopka/autopsy/autopsy-4.19.2/autopsy/modules/org-sleuthkit-autopsy-core.jar: java.lang.UnsupportedClassVersionError: org/sleuthkit/datamodel/SleuthkitJNI has been compiled by a more recent version of the Java Runtime (class file version 61.0), this version of the Java Runtime only recognizes class file versions up to 52.0
End errormessage

No wonder, Java 1.8 and 11 seems to be to old.