Windows Installer doesn't start

I just downloaded Autopsy 4.21 from Autopsy - Download, but when I double click it, it doesn’t run. I tried downloading it from Github but the same thing happens. I don’t get an error message, it simply doesn’t start.
I have an XBook-2 with an Intel(R) Celeron(R) J4105 CPU @ 1.50GHz 1.50 GHz processor, running x64 Windows 11 Pro.

I appreciate your help to get autopsy installed :blush:

The few things that spring to mind are:

If you minimise your window is there a security message that you have to click ok to?
Are you trying to install from your downloads folder?
Do you have Java (JRE) installed?


Thanks for the repy.

No, I did’t get any message at all but yes, I did try to install from my downloads folder :face_with_diagonal_mouth:
I managed to install it by running cmd as administrator but now I get this error message when I try to create a new case:

Please, let me know if I need to post the log file.

Many thanks for your help

Can you please take a screenshot of the page before this? If this is before adding artefacts! With the form inputs, so I can try to duplicate this!

My other suggestion is to run the autopsy as administrator from the start menu and seeing if it comes up with the same error!

Sorry for the long wait. I wasn’t (and still aren’t) able to access the internet on my laptop and had to arrange another one.

The error message was given at the second page when creating a new case.
I read that older versions of autopsy may trigger an error message. So I uninstalled autopsy, removed to folder and reinstall (this time not from the download folder). But the windows installer did not start. I had to install it from cmd just as before.

When starting Autopsy, I did not get the error message above but did get the following:

I am able to run Autopsy though, despite the error.

It might be worth looking at the logs Autopsy User Documentation: Viewing Case Logs and Output

There have been issues with SOLR running on machines in the past (see forum), but the log files will give an indication as to the issue.