Errors opening Autopsy

Hello; I installed autopsy 4.20 on windows 10 ver 21h2 business build 19044.2486 operating system and got the following error messages. Where is the problem? Thank you so much

Hello PiCase,
I am not really professional regarding Autopsy, but since there are many messages concerning Python and Java in one of the provided screenshots I suppose that this could be part of the problem?

Do you have Java and Python installed on your machine?

You do not need to install java or python to install or run Autopsy when you install with the installer. Do you get this error everytime you open up Autopsy? Have you tried to uninstall Autopsy and reinstall it? If you reinstalled Autopsy also delete the directory c:\Users<User Name>\AppData\Roaming\autopsy?

Hi Mark_McKinnon
I get the first two messages on initial setup. Then I get the long log with the screenshot at the bottom. The steps I’ve done are as follows:
I uninstalled Autopsy completely, then deleted all Autopsy related folders under c:\Users\AppData. I even deleted it from regedit. But I am still encountering the same error. Only version 4.17 of Autopsy software runs smoothly on the same computer. This is also a very strange situation. Thank you very much in advance for your attention. Best Regards

Has anyone encountered this problem?