Autopsy 4.18 cluster solr problem

Hello, i have a ruuning autopsy cluster. To upgrade to 4.18 i installed on fresh windows10pro installation solr, using the files and manual from autopsy.
My Problem:
The solr service crashed at start. No solr log, eventlog not helpfull for me.

At my autopsy 4.17 cluster have had same problem, solved with set a variable for JAVA_HOME

Anyone an idea?

Thank you much

Pete

Hello @PeSt. Sorry for delayed response. Have you been able to figure out your issue?

Some notes:

  • JAVA_HOME should not be necessary when installing Solr 8. I have just verified that I have my Solr8 server machines running without this environment variable.
  • There ought to be sole Solr logs in the following directory: (Path to Solr8 directory)\solr-8.6.3\server\logs.
  • Just checking that you are using these latest instructions: Autopsy User Documentation: Install and Configure Solr

Hi @PeSt … I just had similar problems after upgrading. Eventually I worked out that the solr logs dir was missing. For me on Linux:

$ sudo mkdir /usr/autopsy/autopsy/solr/server/logs
$ sudo chmod a+w /usr/autopsy/autopsy/solr/server/logs

I also set SOLR_PID_DIR in /usr/autopsy/autopsy/solr/bin/autopsy-solr.in.sh to /var/tmp

hth