Select Local Disk - Nothing Detected | macOS Catalina

Hello There,

I hope you are well!

I am reposting in this category after not recieving any assitance and realising it may be because it was in the wrong section.

Anyway, I am trying to get Autopsy to scan an old Mac. I have managed to get Autopsy setup and working - to a point. When I try to add a data source, nothing comes up. Refreshing does nothing.

I did find this for Linux:

But of course this relates to Linux. But I wonder if I can add something similar to the Shell Script in Automator that will give me root access or the MacOS equivalent - I suspect it must be a permissions issue?

I tried adding sudo -s to the command line in Automator to no effect. I have just tried adding Autopsy into the Security & Privacy but that hasn’t helped either.

Screenshot 2022-10-06 at 09.01.42

Can anybody help?

Thank you in advance,

For anybody else in this situation, using Logical Mode allows the user to select whatever disk they desire.