postgresql support not supported

Hi,
I am following the steps on this link https://slo-sleuth.github.io/tools/InstallingAutopsyOnMacOS.html#sleuthkitdeps , however I faced a problem during the “Build and Install the Sleuthkit” section.

I ran
export CPPFLAGS="-I/usr/local/opt/libpq/include"
and then
./configure

However, there is no mention of postgresql support once the command finishes.

I tried rerunning the
export CPPFLAGS="-I/usr/local/opt/libpq/include"
however it didn’t appear to change anything.

Any help is greatly appreciated.

Thank you

1 Like

Im having the same issue, did you manage to find a solution?

And you’ve definitely installed libpq via brew right? Do you see anything in /usr/local/opt/libpq/include?
Perhaps it installed libpq elsewhere?

Yes, I did install libpq via brew and I there are files in /usr/local/opt/libpq/include.
I followed this command and then the ones that followed to create the link and to test the link.
brew install ant afflib libewf libpq.

Unfortunately, I still haven’t found a fix

In case you haven’t seen my response on the other thread on this topic…it looks like this is simply a case of the instructions being out of date. The dependency on PostgreSQL was removed in TSK release 4.10.0. You should not need to perform any of the PostgreSQL related steps to build the Sleuthkit Java bindings.