Postgresql support not appearing when I configure

Hello, I am following the Autopsy on on mac os installation guide https://slo-sleuth.github.io/tools/InstallingAutopsyOnMacOS.html#building-the-sleuthkit, specifically I am stuck on the ‘building the sleuthkit’ section. I run the export CPPFLAGS command and then ./configure however the postgresql doesn’t even appear in the building section:

Screenshot 2020-11-19 at 15.15.54

Any help appreciated thanks! :slight_smile:

What does ‘echo $CPPFLAGS’ and ‘ls /usr/local/opt/libpq/include’ show?

when i type ls echo $CPPFLAGS i just get a blank line. postgresql appears to be in the include file.

That suggests that either the ‘export’ command wasn’t right or you have opened a different shell since running that command. The ‘export’ command just sets temporary environment variables in the current shell.
Try the following and let me know what you get.

export CPPFLAGS="-I/usr/local/opt/libpq/include"
echo $CPPFLAGS

Ahh ok, I tried typing those commands and got this result:

I ran the configure again after that the postgresql still does not appear also the java/JNI support has changed to no. Feel like im doing something very obviously wrongly, sorry im not that experienced with terminal :pensive:

Ok, I think the issue is that the instructions are out of date and that in recent versions you should no longer need the PostgreSQL related steps because the code that interacted with the PostgreSQL database was moved from TSK to Autopsy.

As for the JNI issue, you probably need to repeat the steps that set the JAVA_HOME environment variable.