Autopcy for MAC catalina

I am following the steps on this link, however I faced a problem on step number 5.
the “Java/JNI support” is not supported
afflib support: yes
libewf support: yes
zlib support: yes
openssl support: no

libvhdi support: no
libvmdk support: no
postgresql support: yes
Java/JNI support: no
Multithreading: yes

and I think that because I have this error, and really I could not resolve it.
brew install ant afflib libewf libpq


Java -version

openjdk version “1.8.0_252”

OpenJDK Runtime Environment (build 1.8.0_252-b09)

OpenJDK 64-Bit Server VM (build 25.252-b09, mixed mode)

Please, let me know if you can help me to resolve it


@Maram, I suspect you missed a couple of steps. After installing ant you need to uninstall openjdk which is pulled as a dependency to ant.

% brew uninstall openjdk --ignore-dependencies

Then you need to link the liberica-jdk to the openjdk path because ant will be looking for it during the sleuthkit build.

% ln -s $JAVA_HOME /usr/local/opt/openjdk

Check that the link file was created properly (Note that the $JAVA_HOME variable has to be properly set for the command above to work):

% ls -l /usr/local/opt/openjdk
lrwxr-xr-x  1 user  admin  71 Apr 23 17:19 /usr/local/opt/openjdk -> /Library/Java/JavaVirtualMachines/liberica-jdk-8-full.jdk/Contents/Home

Then try the configure command again, but don’t forget to set the CPPFLAGS variable first if you plan to build in postgresql support:

% export CPPFLAGS="-I/usr/local/opt/libpq/include"

thanks for the response actually I did not miss these steps.
I am getting an Error message while downloading ant brew install ant afflib libewf libpq

Error: Failure while executing; tar xof /Users/maram/Library/Caches/Homebrew/downloads/5cf4dd399ddc98aec1fdca0619dfd61a3aea1527a122c0325812a9ddc56ab573--apache-ivy-2.4.0-bin.tar.gz -C /private/tmp/d20200511-52352-1ll9a0f exited with 1. Here’s the output:

tar: Error opening archive: Failed to open ‘/Users/maram/Library/Caches/Homebrew/downloads/5cf4dd399ddc98aec1fdca0619dfd61a3aea1527a122c0325812a9ddc56ab573–apache-ivy-2.4.0-bin.tar.gz’

I tried to download “apache-ivy-2.4.0-bin.tar.gz” manually but unfortunately did not work.

Also, this command returns nothing.

ln -s $JAVA_HOME /usr/local/opt/openjdk

Thanks for the response

The tar error appears be be an issue with the brew package manager, specifically with the apache-ivy package which, as far as I know, is not a dependency of ant (and ivy v2.4.0 is outdated).

Make sure your package list is up to date with

% brew update

Then remove ant, or make sure it is not installed, with

% brew uninstall ant  

Check for brew configuration issues with

% brew doctor

Finally, remove any old, locally stored packages with

% brew cleanup

Now, try to install ant again (There is no need to reinstall afflib, libewf, or libpq):

% brew install ant

If successful, return to the guide. The next step would be to remove the openjdk package that is installed as a dependency of ant and create the link from liberica-jdk home to where ant expects the openjdk you just removed. If the same error occurs, you’ll need to seek a solution with the brew package manager team or build ant manually.

By the way, the silent return of the ln (link) command is normal. Commands often succeed silently in Unix-like operating systems, which is why the guide suggests verifying the results of the link command in the next step. Don’t be surprise if you do get an error if you try to create it a second time and it already exists, however!