Autopsy crash immediately after startup

Autopsy 4.14.0 crashes reproducably after file window is displayed.
OS: Windows 10.0 , 64 bit Build 18362 (10.0.18362.329)

A fatal error has been detected by the Java Runtime Environment:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000aa87426d6, pid=5308, tid=0x0000000000002228

JRE version: OpenJDK Runtime Environment (8.0_222-b10) (build 1.8.0_222-1-ojdkbuild-b10)

Java VM: OpenJDK 64-Bit Server VM (25.222-b10 mixed mode windows-amd64 )

Problematic frame:

C 0x0000000aa87426d6

Failed to write core dump. Minidumps are not enabled by default on client versions of Windows

Can you send along (or paste the content into a response) the hs_err_pid_XXXX file that should have been created for this crash. It’s usually in the %TEMP% folder but if you don’t find it there search your drive for “hs_err_pid”.
Is this a clean install or did you have a previous version of Autopsy installed? If so, which version?
I’d also like to get the log files from %APPDATA%\autopsy\var\log but this forum isn’t good for that. If you don’t have someplace you can upload them for us let me know and I’ll send you a link to someplace you can drop them.

Thanks.

Hello,

Thanks so much for your assistance, full error trace attached plus logs. Yes, there was a previous version installed, but did a clean uninstall/reinstall after the troubles. This is a Windows 10 64bit Autopsy install.

Regards,

Gernot

(Attachment hs_err_pid5308.log is missing)

(Attachment log.zip is missing)

I’ve sent you a message with a link to a location where you can upload those files.

Which version of Autopsy did you previously have installed?
Do you know if you had any 3rd party plugins enabled?

Hehyo! I had exactly the same error which ocurred about 4 days ago. I managed to get a workaround by changing the JVM Parameters in the file “%appdata%\autopsy\etc\Autopsy.conf”.
There is a line which sets the Heap Size, Garbage Collection etc. for Java (All those “-J-” commands). I just commented out that section and set it to “–branding autopsy” only.
Looks like this now (Snippet from ‘autopsy.conf’):


#options used by the launcher by default, can be overridden by explicit
#command line switches
#default_options="–branding autopsy -J-Xms24m -J-Xmx50g -J-XX:MaxPermSize=128M -J-Xverify:none -J-XX:+UseG1GC -J-XX:+UseStringDeduplication "
default_options="–branding autopsy"
#for development purposes you may wish to append: -J-Dnetbeans.logger.console=true -J-ea


Without using those parameters at startup, Autopsy now starts again.
I still do not now what caused the issue in the first place. I had Autopsy running smoothly before.

I am running Autopsy 4.14.0 on Windows 10 (1809) 64 Bit btw.

I’ll play a little more with those parameters to sort out which one causes the JVM to crash.

Regards,
Christoph :slight_smile:

Any resolutions on this matter? Had a clean install on a system and it opens to select new case and then crashes every time. I have deleted and done a new install and the same issue occurs.