Autopsy 4.17 Fatal Error - Java Runtime?

I recently updated to version 4.17 and can’t seem to get it to run now. The only change I made to my system since was updating Cellebrite Physical Analyzer to v7.40, but I’m not so sure that’s what is causing the problem?

When I try to run Autopsy, I see the splash screen but it always closes right after “Starting Modules” shows up. When I checked the error log file, it says, “A fatal error has been detected by the Java Runtime Environment:” Since I can’t upload a log file, I was hoping someone here had run across an error like this and can point me in the right direction. I found a few other posts about Autopsy not running, but those posts didn’t have any replies with which to glean any useful information.

Any help would be greatly appreciated!

The top snippet of the error log is below

A fatal error has been detected by the Java Runtime Environment:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000894a14ed4, pid=13424, tid=0x0000000000003058

JRE version: OpenJDK Runtime Environment (8.0_222-b10) (build 1.8.0_222-1-ojdkbuild-b10)

Java VM: OpenJDK 64-Bit Server VM (25.222-b10 mixed mode windows-amd64 )

Problematic frame:

C 0x0000000894a14ed4

Failed to write core dump. Minidumps are not enabled by default on client versions of Windows

If you would like to submit a bug report, please visit:

The crash happened outside the Java Virtual Machine in native code.

See problematic frame for where to report the bug.

I’m having either the same or a similar issue. I have tried reinstalling both Autopsy and Java individually to no avail. The exception_access_violation error seems to have multiple causes based on my search online and sadly I don’t know nearly enough about Java to figure out what the issue is. For what it’s worth here is my log file :Error Log

Two work arounds that I found that work. The second one is probably the more preferable way.

Extract the files in the file and locate the etc folder in the Autopsy directory structure. Copy and past this folder into your Program Files Autopsy location overwriting the one in there. Reboot and rerun. This worked for me but…see option two below.

Fearing that my previous workaround may not have completely fixed this problem (configuration files pointing to the wrong place, etc), I decided to completely remove Autopsy from my system. Using the Add Remove Programs thing did not remove the Autopsy folder in the AppData folder, nor did it remove the Autopsy folder in the Program Files folder. So I manually deleted both of those folders after running the Add Remove Programs thing and then rebooted my system. I then did a completely new install and everything seems to be working just fine again and I’m confident that the configuration files should be pointing to the appropriate locations.

Try the second method first. If that doesn’t work, try the first.

That worked!
I had tried uninstalling already but missed the AppData folder. For what it’s worth I also uninstalled Java separately though I don’t know if that affected anything. Everything seems to be working now though. Thanks for the help.

The etc from the zip file contains an EMPTY autopsy.conf with all the lines commented out. When I follow your suggestion, it just keeps asking for Java, as logically, there is no java path in the config file.
After trying with several jdk installs, 15 and 11 both give out the error:

org.netbeans.InvalidException: StandardModule:org.sleuthkit.autopsy.core jarFile: C:\Program Files\Autopsy-4.17.0\autopsy\modules\org-sleuthkit-autopsy-core.jar: java.lang.IllegalArgumentException: java.lang.reflect.InvocationTargetException

on launch. At least it’s not crashing with the other error…