Hard Drive Shows but data is RAW and not accessible

Hello all,
So I have a weird situation here. My hard drive recently quit working on me. It was just a storage HD with no OS. When I plug it in a hard drive appears in windows but when I try to view it(Open in file explorer) it says: You need to format the drive to use it.

I ran Acronis on this HD and it says it had 1.5 TB used out of 2TB on it. I created an Acronis image of this disk and restored it on a different drive and it gave me 900GB on a new drive I was then able to access all the files on this new 900GB drive.

When I run Disk Management on this drive it says the drive is not accessible. All the data shows as RAW on this drive.

One of the weridest things is when I plug this drive into a different PC when I open FIle Explorer in Recent Files it actually shows files I recently opened on this hard drive but if I go to view them they are not accessible.

When I run Autopsy on this drive the drive does not appear.

Do I need to format this drive so itll be wiped and then run Autopsy on it so I can recover the rest of my data?

Thank you everyone.