Autopsy 4.19.3 very slow to open case or add data source on Windows 10

After creating a new case file, it’ll just keep loading and I have to wait pretty long maybe 2 minutes and after that another 2 minutes of waiting when try to add data source. Navigating files when selecting a folder also takes a long time to do and isn’t instantaneous. How do I fix this or troubleshoot this problem?

Hi. Can you tell us a little bit about your host hardware configuration? What kind of CPU, how much RAM, what kind of disks? Even on modest hardware, or in a VM, Autopsy doesn’t take long to load or create a new case. Is this the first time you’ve installed Autopsy or did you upgrade from a previous version?

Sure. I have a i7-6700HQ @2.60 GHz, I have 20gb of RAM and SSD disks. 1 128gb ssd and 1 tb ssd. I installed Autopsy on the 128gb ssd where my os reside and it has 12 gb free left. I installed it in the disk where my os resided on because I thought it will be faster but there’s no change at all/
This is the first time I’ve installed Autopsy. I’ve tried uninstalling the latest version and tried an older version and it got even slower so I stick to using the latest version.

Just to rule out memory exhaustion, can you try the following to rule out your system paging out to disk for some reason?

Reboot your machine then start the “Performance Monitor”, select “Performance Monitor” on the left, and then the “+” at the top. Find “Paging File” in that list, select it, and hit “Add”. After that is done start Autopsy and create a new case and keep an eye on your paging file bar which will be a single low continuous bar at the bottom of the performance monitor.


Alright, I’ve done that and the paging file bar is constantly at 0 and does not rise at all when I run Autopsy.

Do you have any other suggestions?

Have you tried to completely uninstall all versions of Autopsy, manually removing the ‘C:\Program Files\Autopsy*’, ‘C:\Users<youruser>\AppData\Roaming\autopsy’, and ‘C:\Users<youruser>\AppData\Local\autopsy’ directories and then reinstall?

yes,the latest verion is even slower for me

Hi @Johith. If you are using Autopsy 4.21.0 (the latest version as of the time of this post) I’d recommend creating a new post here specifically about Autopsy 4.21.0 and include your hardware specs and the size/type of image you are trying to process. Also include information as to whether this is just an initial ingest of the image (with no plugins enabled) or if the ingest is quick but certain plugins you run thereafter are slow. That’ll assist others in helping you debug this.