org-sleuthkit-autopsy-core.jar: java.lang.UnsatisfiedLinkError

Hello, I am trying to run autopsy 4.14.0 in Ubuntu 22.04. I have done the whole setup and now I am getting this error when it’s trying to load the modules.

org.netbeans.InvalidException: StandardModule:org.sleuthkit.autopsy.core jarFile: /home/abhi/Desktop/install-autopsy/autopsy-4.14.0/autopsy/modules/org-sleuthkit-autopsy-core.jar: java.lang.UnsatisfiedLinkError: /tmp/libtsk_jni_abhi.so: /tmp/libtsk_jni_abhi.so: undefined symbol: _ZN9TskCaseDb6openDbEPKcP20CaseDbConnectionInfo

Can someone please help to resolve this error?

Hello. I’d start with installing the latest Autopsy 4.19.2 for Linux and following the installation instructions (autopsy/Running_Linux_OSX.txt at develop · sleuthkit/autopsy · GitHub) to see if the error persists. It could possibly be missing the Java bindings but try start with the latest version and report back.