Display settings (Toolbar view) - Text is VERY small!

I just installed Autopsy 4.17.0 64-bit on Windows 10 and the text is incredibly small. My display settings in Windows is 3840 x 2160 (recommended). It’s the only program with this issue. Any ideas?

I was having the same problem, and assumed it was a VirtualBox (and then a VMWare Fusion) issue. I did the following and it helped me:
-Right click the “Autopsy” launch icon
-Select “Compatibility” tab
-Under “Settings” area, click “Change high DPI settings”
-Under “High DPI scaling override” area, click “Override high DPI scaling behavior” then select “System”

If that alone doesn’t do the trick, you may need to go into Windows settings:
-System–>Display–>Scale and Layout–>Change the size of text, apps, and other items (I’m currently at 350%)

Let us know if you find any other dials to tweak!