Autopsy Error during ingest

I am attempting to ingest an image using autopsy, the image is MUS-CTF-19-DESKTOP-001.E01. The ingest works fine on Autopsy 4.19.1 but I get the error below on 4.19.3 and ingest fails. I have tried a fresh install of Autopsy 4.19.3 and a repair of Autopsy. I have tried Autopsy 4.19.3 on Windows 11 and on Windows Server 2019. The image can be found at 2019 CTF - Windows - Google Drive.

md5 hash of my image that works: 708d3e38acfc9024065e738b063771be
sha1 hash of my image that works: ccb80231ac0e748c14070bc472e5f08053360c08

java.lang.NumberFormatException: For input string: “S”
at java.lang.NumberFormatException.forInputString(
at java.lang.Integer.parseInt(
at java.lang.Integer.valueOf(
at org.sleuthkit.datamodel.WindowsAccountUtils.isWindowsSpecialSid(
at org.sleuthkit.datamodel.WindowsAccountUtils.getWindowsRealmAddress(
at org.sleuthkit.datamodel.OsAccountRealmManager.getWindowsRealm(
at org.sleuthkit.datamodel.OsAccountRealmManager.getWindowsRealm(
at org.sleuthkit.datamodel.OsAccountManager.getWindowsOsAccount(
at org.sleuthkit.datamodel.TskCaseDbBridge.addBatchedFilesToDb(
at org.sleuthkit.datamodel.TskCaseDbBridge.finish(
at org.sleuthkit.datamodel.SleuthkitJNI$CaseDbHandle$AddImageProcess.finishAddImageProcess(
at org.sleuthkit.datamodel.SleuthkitJNI$CaseDbHandle$
at org.sleuthkit.autopsy.casemodule.AddImageTask.runAddImageProcess(
[catch] at

I’ll pass this along to the team.