Add data source ERROT

hi,I want to try to translate autopsy, an error occurs when running the add data source on the compiler,How should I solve this problem?

Thank you !

Can you give us a bit more information:

  • What version of Autopsy are you using?
  • Is this a single user or multi user case?
  • What were you doing when the error occurred? (it looks like adding an image and then clicking global settings on the Keyword Search panel?)
  • Does it keep happening after closing and re-opening Autopsy?
  • Is there anything else in the log? To access the logs, go to Help->Open Log Folder

Hello, thank you for your reply.
I am using autopsy4.13.0, which is a single-user case, I tried to translate some of the, and when I wanted to see the translation, I made an error when adding the data source. I thought it was a mistake in my translation. But the same problem I used when compiling with untranslated source code. When I add a data source, it will be stuck in the position in the diagram.

Thank you!

We’re not sure why this is failing. A couple of suggestions:

  • Do a “clean and build” in Netbeans and then run again
  • Try downloading a completely fresh version of the repo and building/running that

It looks like you’ve including the relevant stack trace, but you could also upload your entire log so we can check if anything else looks strange.

thank you for your reply.
This is the log file generated by autopsy when I run it.
I tried many cleanups and builds on Netbeans, but none of them worked out successfully.
My source code is downloaded on Github. If this is not the complete source code, where should I go to download it, can you tell me?

Thank you!

Since the log file is too large and long, I can’t send a screenshot. Can you tell me how to submit the log?

Thank you for the screenshots, but none of us can see anything obviously wrong and I’m not sure what else to suggest. Maybe someone else on the forum will have some insight.