# Run the autopsy report errors: prompt Solr Keyword Search Service Error

**URL:** <https://sleuthkit.discourse.group/t/run-the-autopsy-report-errors-prompt-solr-keyword-search-service-error/413>\
**Category:** Autopsy Help\
**Created:** [January 10, 2020, 1:29pm UTC](https://sleuthkit.discourse.group/t/run-the-autopsy-report-errors-prompt-solr-keyword-search-service-error/413 "2020-01-10T13:29:52Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![lois\_wang](https://yyz2.discourse-cdn.com/free1/user_avatar/sleuthkit.discourse.group/lois_wang/32/122_2.png) [@lois\_wang](https://sleuthkit.discourse.group/u/lois_wang)\
**Post date:** [January 10, 2020, 1:29pm UTC](https://sleuthkit.discourse.group/t/run-the-autopsy-report-errors-prompt-solr-keyword-search-service-error/413/1 "2020-01-10T13:29:52Z")

</div>

Hello, when I run at autopsy, prompt solr keyword service error, when I select and check the keyword search plugins to continue running, which was a mistake, cause the whole are not running, as shown in the figure below and don’t know how to solve

 ![1](https://global.discourse-cdn.com/free1/uploads/sleuthkit/original/1X/572883bceac1b3a7cd80d91fb14f511dacf79f35.png)  
 ![2](https://global.discourse-cdn.com/free1/uploads/sleuthkit/original/1X/5358ba51882c479f8d25a48ad9c304f0ebd56867.png)  
 ![3](https://global.discourse-cdn.com/free1/uploads/sleuthkit/original/1X/e45b5918d4defabf0a079babe22a8ef1050ed65d.png)

---

<div class="post-metadata">

**Author:** ![atdt0](https://yyz2.discourse-cdn.com/free1/user_avatar/sleuthkit.discourse.group/atdt0/32/202_2.png) [@atdt0](https://sleuthkit.discourse.group/u/atdt0)\
**Post date:** [January 11, 2020, 10:56pm UTC](https://sleuthkit.discourse.group/t/run-the-autopsy-report-errors-prompt-solr-keyword-search-service-error/413/2 "2020-01-11T22:56:28Z")

</div>

Hello.

What version of Autopsy are you running? Years ago I recall there being a similar issue for users that were using foreign languages or had non-Latin characters in their paths. I’m wondering if you are running into that if you are running an older Autopsy?

---

<div class="post-metadata">

**Author:** ![lois\_wang](https://yyz2.discourse-cdn.com/free1/user_avatar/sleuthkit.discourse.group/lois_wang/32/122_2.png) [@lois\_wang](https://sleuthkit.discourse.group/u/lois_wang)\
**Post date:** [January 13, 2020, 9:38am UTC](https://sleuthkit.discourse.group/t/run-the-autopsy-report-errors-prompt-solr-keyword-search-service-error/413/4 "2020-01-13T09:38:05Z")

</div>

Hello,thank you for your reply.  
I am running autospy 4.13.0, my autopsy path is D: \ Autopsy-4.13.0, I tried to use the multi-user function, but after installing solr according to the autopsy document, the keyword search error occurs in autospy Question, how can I solve it.  
Thanks one more!

---

<div class="post-metadata">

**Author:** ![downey](https://avatars.discourse-cdn.com/v4/letter/d/a87d85/32.png) [@downey](https://sleuthkit.discourse.group/u/downey)\
**Post date:** [January 13, 2020, 4:25pm UTC](https://sleuthkit.discourse.group/t/run-the-autopsy-report-errors-prompt-solr-keyword-search-service-error/413/5 "2020-01-13T16:25:19Z")

</div>

If your Solr server is running on a different machine it could be that a firewall is preventing Autopsy from communicating with Solr.  
Confirm that you can connect to it using a web browser on the Autopsy machine. The URL will look like [http://machine-name:8983/solr/#](http://machine-name:8983/solr/#)  
There should also be indications of whats causing the issue in the Autopsy logs. Take a look at the autopsy.log files in the %APPDATA%\autopsy\var\log and your case folder (e.g. F:\autopsy test\33\Log).

---

<div class="post-metadata">

**Author:** ![lois\_wang](https://yyz2.discourse-cdn.com/free1/user_avatar/sleuthkit.discourse.group/lois_wang/32/122_2.png) [@lois\_wang](https://sleuthkit.discourse.group/u/lois_wang)\
**Post date:** [January 14, 2020, 2:17am UTC](https://sleuthkit.discourse.group/t/run-the-autopsy-report-errors-prompt-solr-keyword-search-service-error/413/6 "2020-01-14T02:17:52Z")

</div>

I can successfully connect to 8983/solr/#, and 23232/solr/#, so I don’t know what’s wrong. The following are some of my copied log informatio：

`Solr Keyword Search Service failed to open case resources for 333  
java.util.concurrent.ExecutionException: org.sleuthkit.autopsy.appservices.AutopsyService$AutopsyServiceException: Failed to open or create core for F:\autopsy test\333  
autopsy.appservices.AutopsyService$AutopsyServiceException: Failed to open or create core for F:\autopsy test\333  
org.apache.solr.client.solrj.SolrServerException: Server refused connection at: [http://localhost:23232/solr/333\_20200110\_111345\_20200110\_111350](http://localhost:23232/solr/333_20200110_111345_20200110_111350)  
java.util.concurrent.FutureTask.report(FutureTask.java:122)

INFO: Running Solr command: [F:\autopsy\autopsy13\jre\bin\java, -Xmx512m, -DSTOP.PORT=34343, -Djetty.port=23232, -DSTOP.KEY=jjk#09s, -jar, start.jar, --stop]  
2020-01-10 15:22:46.859 org.sleuthkit.autopsy.keywordsearch.Server runSolrCommand  
INFO: Finished running Solr command  
2020-01-10 15:22:46.859 org.sleuthkit.autopsy.keywordsearch.Server stop  
INFO: Waiting for Solr server to stop  
2020-01-10 15:22:49.273 org.sleuthkit.autopsy.keywordsearch.Server stop  
INFO: Finished stopping Solr serve `

---

<div class="post-metadata">

**Author:** ![downey](https://avatars.discourse-cdn.com/v4/letter/d/a87d85/32.png) [@downey](https://sleuthkit.discourse.group/u/downey)\
**Post date:** [January 14, 2020, 4:12pm UTC](https://sleuthkit.discourse.group/t/run-the-autopsy-report-errors-prompt-solr-keyword-search-service-error/413/7 "2020-01-14T16:12:45Z")

</div>

Is your Solr server running on the same machine as Autopsy or a different machine?  
How have you configured your multi user settings? A screenshot would be useful.

FYI: Single user cases use a local Solr instance that runs on port 23232. Multi user cases typically connect to a network based Solr instance that listens on port 8983 by default. Your multi user settings should be configured to use the network based Solr instance.

The network based Solr instance needs to be able to write to the location where your case output is being stored. This is typically accomplished by using a UNC path as your case output folder (e.g. \servername\autopsy test).

Another thing to check is the Logging tab in the Solr web UI. If your problem is being caused by Solr’s inability to access your case output folder there should be a log message there.
