# How can I fix this error?

**URL:** <https://sleuthkit.discourse.group/t/how-can-i-fix-this-error/3006>\
**Category:** Autopsy Help\
**Created:** [December 20, 2021, 1:42pm UTC](https://sleuthkit.discourse.group/t/how-can-i-fix-this-error/3006 "2021-12-20T13:42:10Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![TheFilthyMongol](https://yyz2.discourse-cdn.com/free1/user_avatar/sleuthkit.discourse.group/thefilthymongol/32/1525_2.png) [@TheFilthyMongol](https://sleuthkit.discourse.group/u/TheFilthyMongol)\
**Post date:** [December 20, 2021, 1:42pm UTC](https://sleuthkit.discourse.group/t/how-can-i-fix-this-error/3006/1 "2021-12-20T13:42:10Z")

</div>

When I run autopsy via command line (exact command is ~/Autopsy-4.19.2/bin/autopsy --jdkhome /usr/lib/jvm/bellsoft-java8-full-amd64) Autopsy opens, but stops when the text above the loading line say “Turning on modules…” and then I get this error:

“org.netbeans.InvalidException: StandardModule:org.sleuthkit.autopsy.core jarFile: /home/username/Autopsy-4.19.2/autopsy/modules/org-sleuthkit-autopsy-core.jar: java.lang.UnsatisfiedLinkError: org.sleuthkit.datamodel.SleuthkitJNI.getVersionNat()Ljava/lang/String;”

without quotations. This error doesn’t directly appear on Autopsy, but a new window pops up saying this. My options are to exit or disable modules and continue. On the command line, these errors pop up:

OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=128M; support was removed in 8.0  
Library not found in jar (libtsk\_jni)  
SleuthkitJNI: failed to load libtsk\_jni

Any idea on how to fix this? I am running it on Ubuntu 20.04 and I am using Autopsy 4.19.2.
